Yes, SaasLand is compatible with WordPress 5.0 and higher versions.

uw partner in de cloud.

volg ons

info@trimessa.nl

+31 (0) 88 2015 200